Tuesday, March 17, 2009

Its a Beautiful Day for Baseball

Most of my co-workers and friends in the Chicago area are loving the weather the last couple of days. Temperatures in the 60's and 70's and sunny. The weather is perfect for baseball.

The problem is there is no baseball in Chicago right now. Its all happening down in Arizona, Florida, and the various WBC locations. So here we are having perfect weather to sit at Wrigley to enjoy a game, and its being wasted.

Good baseball weather during the offseason is a waste, and I hate it. Chicago only has so many nice days in a given year, and wasting them on non-baseball days is dumb.

The worst part about it is that I KNOW I am going to be freezing my ass off at Wrigley on Opening Day. Why? Because I ALWAYS freeze my ass off at Wrigley on Opening Day. You can bank on it. It is almost always cloudy, rainy, snowy, windy, or any combination of those. And it is always cold.

Even when the sun is shining (which is rare), it is cold. There have been a few tolerable Opening Days for those who sit in the sun for even part of the day, but Aisle 424 is like the North Pole in the winter, there is no sun at all up there.

That is a nice attribute in the middle of summer when it is blazing hot and humid, but it is a real drawback until about June of every year.

So I'll sit up there bundled up like an eskimo, drinking over-priced Tepid Chocolate, and trying to fight off frostbite as I try to record the latest 6-4-3 doubleplay for Derek Lee on my scorecard, while thinking back to mid-March when I was wearing short sleeves outside and wishing there was a baseball game going on in front of me.

Not that I'm bitter.

1 comments:

chester said...

A friend in Duluth once told me that there's no such thing as bad weather, just bad clothes. Go to REI and get an "opening day" outfit man! It's a good investment b/c you'll wear it every year! Then wear your Cubs jersey over it :)

Post a Comment

The easiest way to comment is to choose the Name/URL option from the Comment As dropdown menu below. You do not need to put in a URL for this option to work.

Sometimes upon submitting the comment, you will get an error saying there is a problem. Submit the comment again and it should work. I am looking into correcting this glitch.